0
Not a bug

Files and folders uploaded via ftp are not editable in filerun

Robert 7 months ago updated by Vlad R 7 months ago 6

I am trying to upload files and folders via ftp and have a filerun user with the same folder access be able to view/edit the files/folders. I setup ACL's in the folders and added both ftp users and filerun www-data access, the uploads work and I see the files in Filerun account, but I cannot open the jpg's. The folders do not show the full directory structure and the uploaded/ftp jpg files do not open in filerun. The server is ubuntu 18, can you tell me what I may be doing wrong? Is this a folder permission issue or something else?

Answer

Answer

thanks guys! it looks like the chmod change to folder and adding my ftp users to www-data group did the trick. thanks for the tips, that worked!

Under review
cannot open the jpg's

Can you open other file types?

The folders do not show the full directory structure

What do they show, what do they not show?

I can only open files uploaded via filerun, nothing uploaded via FTP is usable. See attached screenshot, the images 1, 2 and ubuntu were uploaded via Filerun and display correctly and I can open them via UI or URL. BUT the file 3.jpg was uploaded via ftp and it doesn't display it correctly or open it. Inside the folder "c" I created subfolders but they do not show at all in filerun UI.

Sorry I forgot to login before posting the comment, but it was me (Robert)

Do a "ls -l" command in the folder to see what happen with this file.

I had to do a chmod and chown to solve a similar problem.


Not a bug

It is obviously a file permission problem. This depends entirely on how your server is configured, what group and permissions the system users under which HTTP and FTP run have.
If chmod doesn't fixes it, you might be having SELinux enabled, in which case you would need to adjust the contexts.

Answer

thanks guys! it looks like the chmod change to folder and adding my ftp users to www-data group did the trick. thanks for the tips, that worked!