0
Under review

Nextcloud Andriod "No files here"

hyyigit 2 weeks ago updated 2 weeks ago 16

Hello,

I completed the installation of FileRun without any problems.
I have a valid SSL certificate.

I downloaded Nextcloud Andorid and successfully logged in.

However, I can't see the content on my server.

I'm not getting an error at any point.

I tried a lot of things, but I didn't get results.
What thing can I miss?

Have you added @Home to the WebDAV path?

Thank you for the quick reply. No, i use only "https://www.creacity.net/filerun/"

The app's connection permission also appears to be seamless. Do I need to type a different link URL?

Under review

No, no need for a special URL. Since you have connected, you provided the right URL.

Which Android version, and Nextcloud app version?

Filerun version: 2019.06.01

Nexcloud Android app version: 3.8.0

Android Version: 8.0.0

Is it possible to work with an older Nextcloud version?

I think you are using another Android App before.
When I log in via Chrome on the mobile device, the following warning appears.

However, the following page does not open.

The same problem exists on the website.
The "Official FileRun app" link does not work.

https://docs.filerun.com/mobile_apps

https://play.google.com/store/apps/details?id=com.afian.FileRun

Thank you.

https://github.com/nextcloud/android/releases?after=rc-3.8.0-02

I tried with 2 different APK on this page. Unfortunately in 3.7.2 and 3.6.2 same result.

+1

The official Android app has been suspended for now.

Are you able to connect to our demo install? https://filerun.com/demo

Yeah, I'm hooked up. I was able to see the files in a directory like @Home.

What is missing in my setup?

I would check the PHP error log, and also the HTTP server log for possible errors.

I checked it in detail. Sorry, no errors occurred during these requests.

I've implemented all of the optimizations mentioned at http://docs.filerun.com/php_configuration.

Unfortunately, I couldn't find a solution.

The problem is definitely on my server computer.

But all the steps proceeded as standard.

You will see the IIS access log records in the attachment document.

According to these records, the application receives webdav information seamlessly.

When I try the same addresses manually, I see the required XML responses.

log.txt

Any other suggestions?

Thank you so much.

+1

I think I know what the problem is. Check the properties of the PHP handler mapping in IIS, and make sure it is configured to allow all HTTP verbs. IIS is currently rejecting PROPFIND, which is the HTTP method for browsing folders via WebDAV (which is used by the Nextcloud apps).

Problem solved. 

However, only HTTP verbs allow was not enough.




When I sent PROPFIND requests directly to the server, I saw a 405 error generated by IIS.

After a little research, I tried the solution on this page and it worked.

https://stackoverflow.com/questions/6147181/405-method-not-allowed-in-iis7-5-for-put-method/54352535#54352535

- Open up IIS and click on your Site
- Double Click on the Modules
- Right Click on WebDavPublishing and remove
- Restart running WebSite

I think it would be good to add this to your documentation.

I had a similar issue, but with other WebDAV client, and I solved it with the @Home.

I tried to enter the WebDAV URL in the nextcloud application but it didn't accept. Which application did you experiment with? Is it possible to type a sample URL?
Thank you.

With a file explorer that supports WebDAV connections. It's not an app that can upload files automatically, for example.

The WebDAV connection is active. I especially wanted to solve the problem in the Nextcloud mobile app. Thank you for your comments.