0
Completed

Fallback to HTML Audio player

Marcel Dopita 3 years ago updated by Vlad R 3 years ago 6

I'm testing FileRun_2016_11_07_PHP7. I have disabled loading of Flash content in Chrome (via settings: Plug-ins [X] Let me choose when to run plug-in content) while I still have option to whitelist a domain. Both Flash and HTML Audio playback works for me but not when it's set to this option.


I prefer not to continue using Flash for audio playback because:

  • this enables automatic loading of all Flash content on my domain (videos in rss reader on same domain)
  • not using Flash allows me to understand what formats I'm able to play on devices without plug-ins (like mobile browsers)

So I'd like to have silent fallback or some toggle (to force HTML Audio) instead of a message "The audio player failed to start. Is Flash missing or blocked in your browser?".

Completed

Perhaps you are not using the latest FileRun version, which is no longer using Flash at all.

Please tell me what browser version you are using.

Your current software version is 2016.11.07 & No software updates available.

I'm using latest Chrome (Version 54.0.2840.98 (64-bit)) on macOS.

Planned

I see. I have reproduced the problem, which only manifest if you change the browser's default settings as you described. It is a very uncommon configuration.


The prompt does not show if one does not have Flash installed or the plugin is specifically disabled (from chrome://plugins).


It will be improved in one of the next updates. Thank you for reporting it.

Completed

The audio player has been rewritten and integrated with the user interface. The change will be available with the next FileRun update. Thank you for reporting the problem!