0
Answered

Lost in setting up filerun synchroisation

norbert 8 months ago updated by Vlad R 8 months ago 4

Hello,

I am trying to set up file synchronisation from my Windows PC to my Filerun Server (which is up an running). Searching for a PC software I am pointed to https://filerun.com/download. There I download and install Nextcloud-2.6.2-setup.exe. Once I open it, I am asked to register with a provider. The small Link "Host your own server" leads me to the documentation on how to install my own Sever.... which is already runnig.


Hw can I get out of this loop?

PS: entering as an address www.mydomain.com/filerun tells me "Server returned Error: no_oauth2" which tells me to login in the broswer. I did that (and I am logged in) but I do not get over this stepp

Answered

You just need to enable the API for the apps to be able to connect: https://docs.filerun.com/api#enabling_the_api

Sorry to bother again, but I am LIGHT YEARS away from understanding that document.That looks to me like a guide for a programer, which I am not. All I need to know, is what to enter here:


Activating that Api changed the error message to: Error transferring https://www.mydomain.com/filerun/index.php/login/v2 - server replied: Not found

I tried adding a Oauth2 client. But it is unclear to me what to do with that data.

Constructing this URL manually is sure not the naswer, is it?

https://www.your-site.com/filerun/oauth2/authorize/?
  scope=email%20profile&
  state=SOME-RANDOM-DATA&
  redirect_uri=https%3A%2F%2Fwww.your-app.com%2Fdo-something-with-the-code&
  response_type=code&
  client_id=f9c6f82cb3e872a20e6a310f33a9c450



The link points to very straight forward instructions:

To enable the API:

  1. Sign-in to your FileRun installation, as superuser
  2. Open the control panel
  3. Browse to Configuration > Security > API
  4. Click the Enable API checkbox and click Save changes

That's it for the enabling. You don't need to add any OAuth2 client.

https://www.mydomain.com/filerun/index.php/login/v2 - server replied: Not found

That URL, when opened manually in a browser, should show the 405 HTTP errors. If it doesn't, your webserver is not configured properly.