0
Under review

missing weblink id error message

stratsimir.trifonov3 4 months ago updated 4 months ago 19

I am testing the free version and consider buying the enterprise as the software is great and works perfectly.

For some files, in Word, I get the error - missing weblink id and I can not get a preview.

For example, in one folder I have 3 Word files, all docx, 2 of them I can open and preview, but the third gets that error. I can download it on my computer, but can not get a preview. 

What might be the reason for that?

Under review

Please specify the method (FileRun plugin) you are using for viewing the files.

The default ones, set in the Control panel, see attached screenshot.

+1

It's just better to post a screenshot of the browser with the error. I will then be able to tell which plugin you are using, if it's the default "Office Web Viewer" or not.

Hi again, here they come - number 1 is the error, number two is a file from the same type in the same folder, number 3 is the content of the folder. Sorry to hide some of the info, but it is a public forum.

Thank you for the screenshots. (I've removed them just in case they might contain private information.)
FileRun is creating a one-time download link to provide to the third-party website Office Web View to download the file in order to generate the preview. If that link is being access, by anybody/anything once, the link no longer works the second time. You will need to figure out who/what is accessing the link the first time. You can do that by checking your HTTP server's access logs.

Hi, in the access log I can see a track of my actions with my IP, but also an IP of Microsoft acessing - 52.149.105.46. I did try to open the 3 documents again and a second document is missing weblink id now. Is it possible that Microsoft is breaking the links?

I need to add that the files are loaded from a base folder which is CHMOD 755, I have uploaded them via ftp. May be change the CHMOD?

I think it's something to do with the file names. I changed the names and the files become viewable. 

I changed the file viewer to Zoho, but it was reporting a similar error, so it is not from the viewer plugin.

But I can not really figure out what exactly in the name breaks the code. Any special characters like dashes, dots, capital letters?

Please mention a filename that fails for you.

I figured it out - it's the capital letters - if there are more than 5 capital letters in the file name - the missing id appears, if less, the file becomes viewable. Weird!

Doesn't seem to apply to any other FileRun installation: https://filerun.com/demo

You are right, there is no error of that type on the demo server.

I also get this mysql error - SQLSTATE[HY000]: General error: 1267 Illegal mix of collations (utf8mb4_unicode_ci,IMPLICIT) and (cp1251_general_ci,COERCIBLE) for operation '='

The MySQL errors are being logged inside "system/data/temp/mysql_error.log" and each error includes the URL it happened. Please include the full entry (you can remove your domain name from the URL).

I suspect your PHP installation might be missing the "mbstring" extension.

What PHP version are you using?