Closed for lack of information

Failed to transfer data. Make sure you are not trying to upload an empty folder.

marco n 3 years ago updated 1 year ago 7


I have installed a "fresh" version (2019.12.25) of FileRun under Virtualmin. Functionality seems to work fine, except for file uploads. I have tried having the user's home directory be both in the webroot and outside, with the same error. I am able to create directories, but not upload any file type. I get the following error message:

A problem has been encountered

Failed to transfer data. Make sure you are not trying to upload an empty folder.

Image 604

I have tried multiple php versions. Currently running under 7.4.8.

Nothing shows up in syslog or web errorlog.

please help.

Under review

It's usually a PHP configuration error. Have you configured "upload_tmp_dir" with the path of an existing folder which PHP has permissions to write in?

same problem..but after 2 days without any configuration change on server (php or other)... re-install... work fine one day and again same problem... i don't understand why this problem apear...

Closed for lack of information

I am having the same problem, it seem to come up more if the file size is larger than 4-5MB, smaller JPEGs seem to upload ok so doesn't seem to be a permission issue, I installed this last week and I don't recall any problems, but I removed it and reinstalled it again (onto a different domain but under the same hosting company so its a fresh setup),  now reinstalling it again onto the same webspace (I removed the domain from CP and recreated again for a clean start) I hit this error, seem very random,

Anyone have a solution to this ?

I got this error as well, is there any way to fix it?

Just throwing this out in case it helps anyone else. Make sure your upload_tmp_dir is in the open_basedir paths. I had changed my temp directory but forgot to add it there and got this issue.

As a weird side note... there were no errors logged anywhere in this instance. If I removed the temp directory entry completely from the ini file, the apache error.log would record an error about unable to create in unknown, and then spit out another line about /tmp not being allowed.  When /tmp was explicitly set as the temp directory, no errors... even though it was still not allowed.

Hi Everyone! Maybe it will help someone.

I have configured security constraints to my FileRun PHP configuration (/etc/php/7.4/apache2/conf.d/filerun.ini) which is called: open_basedir. So, from the scratch, there were no constraints under the PATH variables. But when I have added my folders (suitable for the FileRun application) I forgot to set the /tmp path definition. As a result, I've got the error: Failed to transfer data.

My advise is. Please, make sure, that your open_basedir string looks like:

open_basedir = /var/www/html:/filerun_thumbnail:/tmp or similar.