0
Not a bug

Problem with iconCube

janek 8 months ago updated by Vlad R 8 months ago 2


Hi,

When I try install new version of FileRun in Admin Page:

Developer info: de:1 met:600 ml:2048M
-------------------------------------
Cleaning after previous update...Done
Extracting update...Done
Running update:
-------------------------------------

Fatal error:
The file .../system/data/temp/_unzipped_update/update.php was encoded with the Encoder for PHP 7.1 and can only run on PHP 7.1 or later.
If you are the administrator of this site then please upgrade to PHP 7.1 or later and install the corresponding ionCube Loader. in Unknown on line 0

When I change PHP to 7.1 I see blank white site and:


Fatal error: The file ..../system/classes/vendor/FileRun/Utils/Settings.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later. Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0



How can I instal it?


Thanks.

Answer

+1
Answer
Not a bug

You will find here the instructions on how to upgrade a FileRun installation from an older PHP version to a newer one: https://docs.filerun.com/php7#upgrading_to_a_newer_php_version

I tried to download older version of FileRun and instal it but:

Developer info: de:1 met:600 ml:2048M
-------------------------------------
Cleaning after previous update...Done
Extracting update...Done
Running update:
-------------------------------------
Update script not found!
+1
Answer
Not a bug

You will find here the instructions on how to upgrade a FileRun installation from an older PHP version to a newer one: https://docs.filerun.com/php7#upgrading_to_a_newer_php_version