0
Answered

New docker/synology installation: Failed to write file

kmatheson 2 months ago updated 2 months ago 3

On my Synology DS 218+, I just installed the mySQL and filerun Docker images.  I've been able to login to the FileRun page.

So I login and my existing files aren't shown.  Odd.  So I try uploading a file and get the error "Failed to write file. Server error. Please try again later.".


I try creating a new text file and get the same error.


I stop the FileRun docker container, change the /user-files mapping to a new folder under the /docker share (sometimes my docker containers have better luck reading/writing from there) and retry both functions.  Same error.

I believe that the container does have read/write access to all the folders I've tried.

Do I need to specify the UID:GID somewhere that the FileRun docker container needs to use?

Answered

Once you know the system user which has permission to access the files and what to use with FileRun, find its user and group ID like this: https://www.synoforum.com/resources/how-to-find-uid-userid-and-gid-groupid.77/ Then configure them in the Docker variables.

Where do I configure them in the Docker container?  The Synology docker instructions don't say.

Nevermind, I tried chaning APACHE_RUN_USER, APACHE_RUN_USER_ID, APACHE_RUN_GROUP, and APACHE_RUN_GROUP_ID and it worked.