0

Need help with Filerun in Docker with Elasticsearch

it 3 months ago 0

Hello,

I am relatively new to Filerun. Before, I used Nextcloud, but it is too cluttered and, above all, much too slow. Now I have Filerun running via Docker Compose (also very fast for my taste) and would also like to use the full text indexing. Since I don't have any experience with Elasticsearch, I need your help. The services seem to be running, but "nothing happens".

What exactly do I have to set and do so that the indexing starts?

Here my docker-compose.yml:

### Filerun
### docker-compose.yml
###
###
##START
version: '3'
services:

filerun:
image: afian/filerun
container_name: filerun
restart: always
networks:
- intranet
- internet
ports:
- 80
environment:
FR_DB_HOST: mariadb
FR_DB_PORT: 3306
FR_DB_NAME: mydbname
FR_DB_USER: mydbuser
FR_DB_PASS: mydbpassword
APACHE_RUN_USER: www-data
APACHE_RUN_USER_ID: 33
APACHE_RUN_GROUP: www-data
APACHE_RUN_GROUP_ID: 33
labels:
- "traefik.enable=true"
- "traefik.http.routers.filerun.entrypoints=http"
- "traefik.http.routers.filerun.rule=Host(`cloud.fqdn.tld`)"
- "traefik.http.routers.filerun.middlewares=https-redirect@file"
- "traefik.http.routers.filerun-sec.entrypoints=https"
- "traefik.http.routers.filerun-sec.middlewares=default-headers@file"
- "traefik.http.routers.filerun-sec.rule=Host(`cloud.fqdn.tld`)"
- "traefik.http.routers.filerun-sec.tls=true"
- "traefik.http.routers.filerun-sec.tls.options=myTLSOptions@file"
- "traefik.http.routers.filerun-sec.tls.certresolver=le"
volumes:
- $PWD/data:/var/www/html
- $PWD/userdata:/user-files

external_links:
- mariadb

links:
- tika
- elasticsearch

tika:
image: logicalspark/docker-tikaserver
container_name: tika
restart: always
networks:
- intranet

elasticsearch:
image: docker.elastic.co/elasticsearch/elasticsearch:6.2.4
container_name: elasticsearch
restart: always
networks:
- intranet
environment:
- cluster.name=docker-cluster
- bootstrap.memory_lock=true
- "ES_JAVA_OPTS=-Xms512m -Xmx512m"
ulimits:
memlock:
soft: -1
hard: -1
mem_limit: 1g
volumes:
- $PWD/esearch:/usr/share/elasticsearch/data

networks:
intranet:
external: true
internet:
external: true

Kind regards

H-BLOGX