0
Under review

Google Docs editor not working behind reverse proxy?

Scion 4 weeks ago updated by Vlad R 3 weeks ago 2

When we first installed FileRun on our original host, the Google Docs editor worked fine. However a while back we moved our FileRun installation from 'mydomain.com/filerun' to 'sub.mydomain.com/filerun' which is on a different machine.

We got the installation working perfectly after editing the configuration files as you suggested in another topic, but the Google Docs editor now only returns a 404 when it opens the new popup.

I tried changing some of the URI configurations around between the primary domain and the subdomains, but still keep getting a 404.

Is this an issue with my configuration in the Google Api side or the FileRun side?

I should clarify that the 'sub.mydomain.com/filerun' is accessed through a reverse proxy on 'mydomain.com/filerun'.

Under review

You would most probably need to update the API credentials in the Google developer console (https://console.developers.google.com/apis/library), in order to update with the new authorized URLs.

Otherwise it should work fine behind a reverse proxy.