0
Not a bug

FileRun opens files in OnlyOffice with option auto-save off. With OO example file auto-save is always on

Rudhra 6 months ago updated 4 months ago 5

I think this is a bug. I use Docker on Ubuntu. To reproduce:

1. Go to When i go to https://onlyoffice.mydomain.com,
2. OnlyOffice welcome page is shown. follow the instructions to enable the example and create a new doc from the example.

3. In File>Advanced Settings notice Autosave is enabled.

4. Go to FileRun, create a new OnlyOffice Document. A new browsertab should open OnlyOffice with a blank document. The url of the tab is https:// filerun.mydomain.com...

5. In OnlyOffice File>Advanced Settings notice Autosave is disabled.

6. Enable it, edit doc, close it.

7. Reopen the doc from Filerun or create a new one. In OnlyOffice File> Advanced Settings notice Autosave is disabled. 


This means each time I open a document, I have to enable auto-save, but it is only saved for that session.

The OnlyOffice example shows auto-save is enabled by default within OnlyOffice.

This issue is also discussed here, confirmed to be an issue with integration (I did not mention FileRun).

https://github.com/ONLYOFFICE/Docker-DocumentServer/issues/345

Answer

Answer
Not a bug

If you open "customizables/plugins/onlyoffice/app.php" in a text editor you can change "autosave" => false to "autosave" => true

It is very unconvenient auto-save is not on.
OnlyOffice DocumentServer example does show auto-save to be on by default. So this is related to FileRun.


Can this please be investigated?

I really do not need prompt support or a reply. I am just a home user, no need for enterprise level support.

But I can imagine this bug is affecting more people. Just an acknowledgement would simply not lead to confusion of me thinking you might have missed this report. Even if I get a response once a month I am already happy. Thank you for your hard work btw. The latest release is just awesome.

You actually have a functional tester with me, at zero cost :)


Answer
Not a bug

If you open "customizables/plugins/onlyoffice/app.php" in a text editor you can change "autosave" => false to "autosave" => true

THANKS so much!!

Is there a way to add something to so that we can set the defaults for "REGIONAL SETTINGS" (it is now always US English) and Spell checking> "DICTIONARY LANGUAGE" (default is English Australia) ?

Screenshots below, this is when opening a file in editing mode:

Solved!

In the same file: 

under  "editorConfig" =>

Add/change the following: 

				"lang" => "nl",
"location" => "nl",
"region" => "nl-NL",

To change the default spell check language for all documents, you have to open the docx/xlsx/pptx blank documents, change the region/language via the bottom icon/advanced settings and save the files.

These documents are located in the same plugins folder: docker/filerun/html/customizables/plugins/onlyoffice/blanks

I now have a Dutch UI for OnlyOffice with Dutch spell checker by default :)