0
Started

Unable to upload files using shared links with message "The followed link is not valid."

lloyd.dunn 1 month ago updated by mikel 3 days ago 9

This was working a week ago with PHP7.2 and the previous Filerun. People using shared links successfully uploaded files to our instance of FileRun.

Then, my server provider encouraged upgrading to PHP7.4, so I did. At the same time I upgraded to the latest version of FileRun 2021.03.26. I had to upgrade Ioncube, too. Now everything works, except for users of shared links are unable to upload files, getting the message "The followed link is not valid."

I tried it, it appears to upload normally. But then that message appears.

Please, what should I look for? I believe I have configured php.ini right according to the documentation. You can see it here: http://agosto.space/phpinfo.php.

You can try one of the nonworking shared links (password is "JF"): http://agosto.space/wl/?id=LhMCKJAJ38ulHFa6gllYzB1uP3rO5tht

Any insight will be greatly appreciated. Thanks.

Never mind, I fixed it by downgrading FileRun to a version from 2020. Is there a bug in the latest FileRun?

Anyway, it's all working for us now.

+1
Started

Thank you for pointing it out, we confirm the bug and we'll fix it shortly.

Hi Vlad, any idea when you will fix? 

Best, Philip

A patch that fixes this problem can be downloaded using the following link: https://bit.ly/3swjD44

The update that gets installed via the FileRun control panel has been now patched as well.

Couldn't fix the problem even patched the files...

You might need to clear your browser's cache.

 Patched but same error. Tried with different browsers.


Manually Pached and working, thanks!

The anonymous message is from me, don't pay attention, I had tried to install the patch by uploading updates in the control panel.