0
Fixed

Vips fails with Chinese (or any other non-latin) characters

filerun 5 months ago updated by Vlad R 4 months ago 9

Filerun version is 2021.12.07.

System: Ubuntu 20 LTS

vipsthumbnail --version
vips-8.12.1-Wed Nov 24 15:41:04 UTC 2021

Sorry for my bad english, let me take screenshots to show you the problem:

Answer

Answer
Fixed

A FileRun update is available for installation. It should fix this regardless of the server. Thank you all for helping me fix this.

+1
Under review

Thank you for reporting this, I am looking into it.

Not only with chinese. Same thing with foldernames with russian characters.

Seems to be poor support for Unicode filenames in Vips. I opened a bug report with Vips dev: https://github.com/libvips/libvips/issues/2599

Somebody reported that he got this working with German characters by changing the system locale to de_DE.UTF-8

Not so easy to do that using Docker though.

I try to set system locale to zh_CN.UTF-8, Its works in ubuntu command line, but still don't work in Filerun.

I don't use Docker.

Polish characters  is  also a problem for Vips. I using docker-compose and have some problem but I just rename some directories and it's works.

Temporary solution:

1、Make sure that you have /usr/local/bin/vipsthumbnail and /usr/bin/php

2、download this file, edit it , change "LANG=zh_CN.UTF-8" to your country language code, mv this file to /usr/local/bin/ , and give it executable privileges

3、on filerun Control panel, Files -> Thumbnails and preview -> Path of "vipsthumbnail" binary, set it to "/usr/local/bin/vipsthumbnail-fix"

vipsthumbnail-fix


Note this is only a temporary solution and may not be the best solution.

Started

Until vips gets fixed, here is an easy workaround for this problem.

Create the file "customizables/config.php" (if does not exist already) and have it read this:

<?php

putenv('LANG=C.UTF-8');
Answer
Fixed

A FileRun update is available for installation. It should fix this regardless of the server. Thank you all for helping me fix this.