0
Under review

Enpass Passwordmanager with the Webdav Sync

mbasdf 1 week ago updated 9 hours ago 5

Hi guys


I installed FileRun with a Docker container on my Unraid server.

So far everything looks good, but as a part of the integration I tried to connect my Enpass app over the webdav API.

As connection URL I used <myhost>/dav.php/@Home/ and my credentials (also I tried without @Home or with the encoded part of the @).

Then in the log of filerun I got the following lines:

"PROPFIND /dav.php/@Home/ HTTP/1.1" 207 10085 "-" "Mozilla/5.0 Enpass"
"PROPFIND /dav.php/@Home/ HTTP/1.1" 207 10085 "-" "Mozilla/5.0 Enpass"
"PROPFIND /dav.php/%40Home/Enpass/vault.enpassdbsync HTTP/1.1" 409 217 "-" "Mozilla/5.0 Enpass"
"PROPFIND /dav.php/%40Home/ HTTP/1.1" 207 10113 "-" "Mozilla/5.0 Enpass"
"PUT /dav.php/%40Home/Enpass/vault.enpassdbsync HTTP/1.1" 409 234 "-" "Mozilla/5.0 Enpass"
"PUT /dav.php/%40Home/Enpass/vault.enpassdbsync HTTP/1.1" 409 234 "-" "Mozilla/5.0 Enpass"

Then funny thing is, there is already a migrated Enpass folder and also files in it.

So it seems that it don't get that files and that Enpass could not write the new file.

On the other hand, when I bind the WebDav folder with Cyberduck I can access all folders and can also read/write files.

What do you think where the problem could be?

Thank you.

Under review

Any error logged in the FileRun user activity log, in the control panel? Is the FileRun user allowed to upload and modify files?

No unfortunately not.

I only see the successful OAuth hook, when I once tried the Enpass Nextcloud integration (they have WebDav & Nextcloud).

But both did not work.

I think the login is working pretty fine but then it can not fetch the required data.

And yes, the user is allowed to do any changes and downloads on that files.
This particular user has more or less all checkboxes set.

@Vlad R I was able to check the Enpass logs.

Enpass can fetch the Webdav home folder (<myurl>/dav.php/@Home/) and lists all the folders there and it also founds the Enpass folder.

But then it is not able to read the Enpass file because of permission issues (401, followed by a 409).

On my side the file has the same permissions as every other file and even the Home folder.


Does that help? Any more ideas?

Here is a patch that should fix this problem.

Download "this file" and use it to replace in your FileRun installation the file "system/classes/vendor/FileRun/WebDAV/Methods/PROPFIND.php".

The patch will be included with the next update.

Wow. Thank you.

That works like a charm. 👌

Thanks for the fast fix!