0

Mobile and Desktop app not working properly

florian_breuker 1 month ago updated 4 weeks ago 3

Hi guys,

currently I'm struggling with the App integration.
I've enabled the API in the Control Panel, but the Desktop-App keeps throwing this


Now in English:
Could not parse the JSON returned from the server: illegal value

And the mobile app allows me to connect to the server, but i can't save the connection... so i need to add the URL every time i open Nextcloud Mobile.

I need both of the apps to grant easy access to the cloud for my family.

After reading through the forum i tripped over this post:
https://feedback.filerun.com/en/communities/1/topics/1613-nextcloud-connection-problem

he is having the same problem, but it hasn't been solved till now. (but is marked as solved :(...)

I can access the dav.php and i am getting back the xml...


But the apps still doesn't work properly...

This is my NGINX.conf...
Should be the same as mentioned in the tutorial:
http://blog.filerun.com/how-to-install-filerun-on-ubuntu-20-with-nginx/

server {
server_name mydomaine.com;
root /var/www/html/;
index index.php index.html;

location / {
try_files $uri $uri/ /index.php;
}

location ~ [^/]\.php(/|$) {
fastcgi_split_path_info ^(.+?\.php)(/.*)$;
if (!-f $document_root$fastcgi_script_name) {
return 404;
}


include fastcgi_params;
include snippets/fastcgi-php.conf;

fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
fastcgi_param PATH_INFO $fastcgi_path_info;
fastcgi_pass unix:/run/php/php7.4-fpm.sock;
}

# A long browser cache lifetime can speed up repeat visits to your page
location ~* \.(jpg|jpeg|gif|png|webp|svg|woff|woff2|ttf|css|js|ico|xml)$ {
access_log off;
log_not_found off;
expires 360d;
}

# disable access to hidden files
location ~ /\.ht {
access_log off;
log_not_found off;
deny all;
}

listen [::]:443 ssl ipv6only=on; # managed by Certbot
listen 443 ssl; # managed by Certbot
ssl_certificate /etc/letsencrypt/live/servker.ddns.net/fullchain.pem; # managed by Certbot
ssl_certificate_key /etc/letsencrypt/live/servker.ddns.net/privkey.pem; # managed by Certbot
include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

}

server {
if ($host = mydomaine.com) {
return 301 https://$host$request_uri;
} # managed by Certbot


listen 80;
listen [::]:80;
server_name mydomaine.com;
return 404; # managed by Certbot


}

I hope someone could find the mistake.
If you need any further conf files i would send i to you.

Yours,
Florian

Hi,

so I'm using the Nextcloud Android app, the Owncloud desktop app for Linux, and Mountain Duck for Windows to sync. So far all work flawlessly, I haven't encountered such issue yet.

I do however have a completely different server setup... with Nginx as a reverse proxy and an Apache server runnning Filerun. So either you're entering wrong data into the Nextcloud client or there's something wrong with the Nginx config.

I won't be able to help you with the nginx config, but if you prefer I could give you my nginx + apache config...

+1

Hi brwPfdGqJGX,

Currently its working fine. I moved the whole filerun-environment to docker.
Docker is using the apache as webserver and nginx-proxy-manager for the ssl certificate.

I think there is some problem with the nginx.conf file and i priviously had problems with a to old docker and docker compose version due to the outdated debian repo (using ubuntu as base os)

But thanks for your reply and help