0
Under review

suddenly cannot download file larger than a few megabytes after fixing upload problem

maxloo2 3 weeks ago updated by Vlad R 2 weeks ago 15

runing filerun on proxmox, behind haproxy on pfsense. everything was fine until I fixed my upload problem as mentioned here: https://feedback.filerun.com/en/communities/1/topics/1632-500-internal-server-error-on-large-uploads

now I cannot download most of my files on the server, every time I download a file that is larger than a few megabyes (somewhere around 10~20MB) the file will fail to download to "network error" on chrome, or become a "download.htm" file with "Invalid Request" written inside. everything else seems to work just fine.

download accelerator is not enabled. increasing the filerun.ini php values doesnt seems to fix the problem either.

I have only successfully downloaded an affected file once, I had to download from a previous file version. But after the first success it never worked again anymore.

the only error I found is in /var/log/nginx/error.log: pwritev() ... has written only # of # while reading upstream ...

Under review

The logged errors relate to downloading folders. Are your problems related to downloading single files, or folders as zip?

I have tried all of them, from left to right: 12MB file, a 100MB file, and a folder (with both these files inside).

I have no problem downloading the files thru SFTP with WinSCP, nor is there any problem viewing the file on the web. I also have no problem uploading or deleting the file.

You should test the download without any proxies, I'm 99.9% sure that that's where your problems are from.

Hi I tried to access it directly using internal IP but got the same result. And again it used to work 100% fine, I never changed anything on my router so I doubt HAProxy/ PFSENSE has anything to do with this problem.

Do disable the use of a download accelerator, if set in FileRun control panel (i think it's under Files > Misc).

I have never enabled it to start with...

The "download.htm" if you open it in a text editor, what do you see inside?

this info is provided in the original post... "Invalid Request"

.. after you down load it directly from the FileRun server, not via proxies.

same result, "Invalid request"

Please post a <?PHP phpinfo() output from the server

phpinfo: https://imgur.com/a/C2Um2k8

I was unable to even upload to my filerun server so I reinstalled it again, this time keeping most settings at the default values, and I am able to download some larger files now, the limit now is 400MB, any file that is larger than that stops downloading after a few seconds/

Another interesting oberservation is that if I start multiple smaller downloads at the same time, some of the downloads will fail. I assume that the problem has to do with the amount of data the server has to handle in one go.

Anyway the error is still the same, either "Failed - network error" on Google Chrome, or download.htm with "Invalid Request" written inside the file. But I am getting more download.htm than the browser error, I think it is because it can now at least start downloading some of the file instead of not starting the download at all.

I can't download or load the phpinfo image. Please use this form to provide temporary test account to your instance, so that I can have a look: https://filerun.com/contact

I have sent the support email already, please tell me if you have any problems accessing it, thanks!

I received it, emailed back to provide access to some file to download as at the moment there is no content or possibility to add any.