0
Under review

After server reboot Owncloud always re-downloads everything

Zilexa 2 weeks ago updated 2 weeks ago 6

I have 600GB in sync through Owncloud Desktop Client on a laptop, 3 FileRun accounts.

FileRun is installed through Docker Compose. All works fine.


However, if I re-create the container or simply restart docker or the whole server, the next time I open my laptop, OwnCloud says the whole root of each folder is deleted on the server (which is not true of course, nothing changed on the server!) and it will re-download everything.


It has done so 4 times already this year, not a healthy thing for my 1TB ssd. Now it wants to do so again.


Is there a way to solve this? It might be a slight incompatibility with Filerun?

Under review

Any chance the file/folder creation/modified dates change in the process?

I was on holiday last week. Got home, opened laptop and saw the Owncloud warning. I shut down Owncloud to prevent it from doing anything.

right before I went on holiday, I rebooted the server. That's all I did. Before the reboot, I did not touch the server for over a month.


Every day, my mobile phone syncs several folders to my account. That continued during holiday, normally.     

Just jumping in, I saw this behavior on NEXTCloud; quite disconcerting to discover that Owncloud suffers from this behavior as well. I can only guess that "enough" of the file metadata was changed to force a re-download; perhaps the filesystem on the server is wonky and is fooling Owncloud into thinking there are changes where there are none.  My issue was due to a shared host backing up their data; once the folders were touched by the backup job, they were considered changed.  So I am wondering if the reboot is causing some underlying file system issue.

In my case, backups are made nightly, so that cannot be the issue, I do not have this issue every day.

Also, in my case I use BTRFS filesystem that supports snapshotting. So a backup process is a snapshot of the underlying subvolume that contains my data. Metadata is not changed.

Also, in fstab, my filesystems are mounted with option "noatime", this disables files being updated just to change the last access time. I believe this is a common best practise, only use access times if you have a use case for it.

It is quite an annoying issue, not sure what information Next/Owncloud desktop clients use to base their decision on re-downloading everything. The message clearly points to the root folder being deleted. If you accept, it will simply re-download everything (so the message is incorrect, since the folder exists) and overwrite existing data.

Are you using Docker volume for accessing your storage, or a Docker bind mount?

FileRun/NextCloud/Owncloud e-tag is generated like this:

MD5( file-modified-timestamp .file-inode-number . file-device-id . file-size )

I have seen cases where remounts/restarts changes either inode or the device id, messing with the etag and causing resyncs. It's probably the same case.

I use docker compose to create the container, with a persistent mount, like this. Following documentation:

    volumes:
      - $DOCKERDIR/filerun/html:/var/www/html
      - $DATAPOOL/users:/user-files

I guess that could then be the cause, is there a solution?

(The 2 variables are in my .env file. When the compose file is parsed, the full path is shown)