Google docs editor is not working

richard1996ba 5 years ago updated 2 years ago 18

I tried to integrate google docs editor but this message appeared.

400. That’s an error.

Error: redirect_uri_mismatch

The redirect URI in the request, http://mywebsite/?module=custom_actions&action=google&method=getToken, does not match the ones authorized for the OAuth client. To update the authorized redirect URIs, visit: https://console.developers.google.com/apis/credentials/oauthclient/infos?project=42500xxxx561

Learn more

Request Details

How can I fix this problem?



The user did not configure the authentication inside Google correctly.

My client id isn't info or my website is not my website. I changed them for privacy reasons.

Under review

Google says the redirect URI configured does not match yours (http://mywebsite/?module=custom_actions&action=google&method=getToken)

Having the URIs match should fix the problem.

The error message from Google is clear and self explanatory. The URL (http://mywebsite/?module=custom_actions&action=google&method=getToken) is not configured inside the Google console. Configuring it will fix the problem. Google is rarely buggy and their error messages include the solution. This is not a FileRun issue, but a configuration issue inside the Google account.

So now it works?

If it doesn't, Google believes that the configuration is not correct.

No. I checked the configuration and they are correct.

It sounds like you need to take it up with Google in this case.

What FileRun version are you using?

Feel free to contact us privately (https://filerun.com/contact) with access to your FileRun installation, so that we can check this problem for you.


The user did not configure the authentication inside Google correctly.

The user still can't login

502 Bad Gateway 



Please contact your server administrator about it.

I am the server administrator.

This thread is about Google editor. If you are having some other issues FileRun related, please open a new one.

Also, if you wish to receive assistance, please provide proper troubleshooting information. "The user still can't login" is not enough. Specify which user, login method, URL, browser version, app version, server information, HTTP access and error log related entries. I am pretty sure that when you will start collecting this information you will find the problem, and the solution.

Superuser, Google account, all.hxxxxx.xx, Google Chrome v64.0.3282.186, 502 error bad gateway.