0
Not a bug

Cannot login in new version (Windows 10)

dannychow 3 years ago updated 2 months ago 8

I 'm using a Windows 10 as server. I installed PHP7.2.2 (64 bits) and using the newest Filerun (FileRun_2018_02_13_PHP71). I could see the welcome page and input all the database information. It also could show the superuser account information to me. But when I tried to login using the super account, it bounded back to the login page. Please see the error log of the PHP below. Any idea how to solve it?

  

[27-Feb-2018 17:45:14] PHP Warning:  session_regenerate_id(): Cannot regenerate session id - session is not active in D:\FileRun_2018_02_13_PHP71\system\classes\vendor\FileRun\Auth.php on line 72
[27-Feb-2018 17:45:14] PHP Warning:  Cannot modify header information - headers already sent by (output started at D:\FileRun_2018_02_13_PHP71\system\classes\vendor\FileRun\Auth.php:72) in D:\FileRun_2018_02_13_PHP71\system\modules\fileman\sections\default\php\login.php on line 119

Answer

Answer

After I configured a valid path for "session.save_path", I can login right now. Thanks.

Under review

Might have been a temporary issue. Try logging in with a different browser and let me know if the problem persists.

Also, make sure PHP is configured with a valid path for "session.save_path".

Answer

After I configured a valid path for "session.save_path", I can login right now. Thanks.

same problem on fresh install on rhel8. This solution  didn't worksfor me. I used the latest filerun 

If you upload the file "https://goo.gl/ens592" (phpinfo generating PHP script) to your server and send us its URL or output, we can help you better with the PHP configuration information it provides.

php.ini

same problem here, do assist me plz

Your "include_path" is wrong. It needs to include ".;".

I also am having this issue with version 2019.12.25.PHP.71-73 running on windows 10 (home) IIS w/ PHP 7.4.  I have configured the sessions.save_path, and can see ses_(random) files in the session folder after each time I try to login.  

Here is my php.ini

For reference purposes here is what I have enabled in  (ControlPanel\Programs & Features\Turn Windows Features on\off) Screenshot   I used the WebPlatform Installer to install php 7.4 and then used the FileRun PHP config guide to edit my php.ini

I'm in the process of setting up a Windows 10 pro  IIS server, and will try to use the same setup versions (PHP, ION loader) as the Home computer.  Once I have tested it out on Windows 10 pro to see if that makes a difference I will report back.