0
Answered

NextCloud desktop client: Internal Server Error

80apk 3 years ago updated by Vlad R 3 years ago 18

Hi,


Today I noticed that my NextCloud desktop client was not connecting to my FileRun server. When I try to connect, the client displays the following message:


  • Error transferring https://[my filerun installation folder]/remote.php/webdav/ - server replied: Internal Server Error

Any ideas what might be causing this behaviour? Everything was working fine until this morning.


Thanks in advance.

Gareth


It might also be helpful to know that I also get an "Internal Server Error" message when I try to connect to 

https://[my filerun installation folder]/dav.php/

using my browser.

Under review

Please check your configured PHP error_log file for details relating the particular requests. Post them here if the log entries do not point you to the solution.

Thanks for your reply.


Below is an error log entry I suspect may be related to the problem:


  • [Fri Mar 16 09:59:23 2018] [crit] [client xxx.xxx.xxx.243] [host www.my-domain-name.com] AH01505: Regular expression replacement failed for 'HTTP_AUTHORIZATION', value too long?

I found this in the error log in my shared hosting account. And the dates and times in the log file coincide with my attempts to connect to the FileRun server.

The PHP error log will provide more useful information. For guidance on accessing the PHP error log, I recommend you to get assistance from your hosting service tech support.

My hosting tech support has informed me that the entry I posted above is a PHP error log entry. 


Also, they're trying to tell me that the problem has to do with the fact that the webdav protocol is no longer enabled for shared hosting customer. According to them is was stopped in 2012. But this can't be true, since up to the day before the error started occurring (16/03/2018), I was able to connect to my FileRun server normally via NextCloud, as the web log entry below shows:


  • xxx.xxx.xxx.xxxx www.xxxxxxxxxxxx.com - [15/Mar/2018:21:38:15 +0100] "PROPFIND /vofilerun/remote.php/webdav/@Home HTTP/1.1" 207 595 "-" "Mozilla/5.0 (Windows) mirall/2.3.1 (build 8) (Nextcloud)"

Thoughts?


Sorry, but your hosting tech support is wrong. The log entry you posted earlier is an Apache error log entry which related to the "mod_setenvif" module. It is not a PHP error log entry.


Also, the WebDAV protocol is not something you enable or disable. Perhaps they are referring to an Apache module for having WebDAV access by default.

Given that WebDAV is based on the HTTP protocol FileRun does not require any server configuration for it to work (other than not disabling certain HTTP methods).


It seems the tech support guy I was dealing with had it all wrong. 


He subsequently informed me that he had escalated my ticket to the next support level, and then came back to me to suggest I try changing my "hosting configuration" from "Legacy" to "Stable" (screenshot below). That didn't work. Waiting to hear back from them...






Can you connect to FileRun using other WebDAV clients? http://docs.filerun.com/webdav

Tried with Cyberduck. Nothing doing.

Try removing the ".htaccess" file from FileRun's installation folder.

1. Changed the ".htaccess" filename to ".htaccess.old"

2. Tried logging in from browser ---> OK (a little slow the first time)

3. Tried logging in from NextCloud client ---> Error message (displayed in French, but translated as): "Access impossible. To check access to the server, click here and log in to the service from your browser"

4. Log in from browser ---> OK

Do try a regular WebDAV client and let me know if the error is the same as before.

Tried using WinSCP with the following settings:

  • File protocol : WebDAV
  • Encryption: TLS/SSL Implicit encryption
  • Host name: www.my-domaine-name/filerun folder/dav.php/
  • Port number: 443
  • Username: ****
  • Password:****

Window appears displaying:

      Connecting to host...

      Authenticating...

      Access denied.


... and asking me to enter my password.


When I enter my password (again) and click 'OK',  'Access denied' is displayed in the same window. This happens every time I enter my password and click 'OK'.


Answered

This confirms the problem lies with your Apache server. Nothing to be done about it on the FileRun side. Your server administrator or hosting service tech support is responsible with helping you with this problem.

I suspected as much.

I'll rename the '.htaccess.old' file to its original name, and continue to pursue the matter with my hosting provider.


Many thanks for taking the time to help me with this issue, Vlad!


I was wondering: Is Vlad a generic name used by several people providing support for FileRun, or do you provide all the support yourself? If the latter, how do you manage? Amazing! How much sleep do you get :-)


Thanks again.

G

Same person, doing my best :)

Hey Vlad!

I'm pleased to report that I've solved the problem. Or maybe I should say that the problem is now solved.

I had initially been running FileRun with PHP v. 5.6 because my hosting provider had told me that ionCube was only available with that version but not with v. 7.0. 

Earlier this evening I decided to check myself and found that ionCube was in fact available with PHP v. 7.0. So I switched from PHP 5.6 to 7.0 and now everything is working perfectly.

To look on the positive side: I'm now running FileRun with PHP 7, which should mean better performance.

Cheers!

Good to hear that! Indeed performance should be considerably better using PHP 7.