Cannot Delete Files

dennyhz 4 years ago updated by Vlad R 4 years ago 9

I got everything setup very nicely but am having one problem. I cannot seem to delete files. When I try to delete a file, I only get a brief toast message in the bottom left corner which just has the letter "F"....and the file is not deleted. Kind of strange.....

I am running Filerun via Docker Container but I was sure to give the the Filerun container the correct PUID and PGID settings to it had proper permissions.

Oddly enough, if I create an empty folder, then select both the empty folder and the file.....I can delete both just fine. It is only when I select just files that delete fails.

I think this is a permission issue.

If you create a Folder and upload a File to it, can you delete the File again?

I think that you copied files into FileRun folders which belongs to other users and now you want to delete it but you cant because the user which want to delete the Files is not the owner of the Files.

Any logs?

I tried your scenario:

I enter FIlerun as the user=superuser (the one automatically created by Filerun during first install). I create a folder in Filerun, check permissions for it (it is nobody:users). I create a file in that folder, check permissions for it (it is nobody:users). I get the "F" message when trying to delete the file newly created. File not deleted.

  • All files created or copied by FileRun are user=nobody group=users (this is independent of the user used inside Filerun)
  • nobody:users is the standard user:group UnRAID uses which allows R/W access.
  • Upon Filerun container creation, I set PUID to 99 and PGID to 100 using the Docker Parameter flags. 99:100 corresponds to nobody:users.
  • I confirm this works because every file/folder I create in Filerun is set to nobody:users
  • I am not able to delete a file unless a folder is selected along with it.

Are the user and groups which are used to login to Filerun actual Linux users/groups? Or are they just something internal to Filerun?

Under review

When deleting a file, FileRun creates a hidden folder called ".filerun.trash" inside the user's home folder, where the file is supposed to be moved. For this, the permissions of the user's home folder need to allow the action. Check if the folder exists and PHP has permission to move the file to it.

(The FileRun users are completely separate from the system users.)

Thanks for helping. I will look into this once I get my Filerun GUI up and running again. Hope I can get back up and running :(

Ok, I used the custom setting to re-route my trash folder to another location which has RW access on all users. Delete works now.

@dennyhz how did you do this?
can you post it here?

See "$config['path']['trash']" config option on this page: http://docs.filerun.com/advanced_configuration