Closed for lack of information

Cannot Download Large Files

marlee redmann 4 years ago updated by Vlad R 4 years ago 4

I cannot seem to download a large zip file no matter what I do. It's just shy of 10GB. It downloads at most, 7.5GB and then says it's finished. The file size of the zip file is 7.5GB but it says it's empty, there is nothing in it. First I tried downloading the folder from File Run, so that File Run did the zipping, that didn't work. Then I tried actually uploading a zip file, and then downloading it, same issue. 

I have upped my memory_limit to unlimited, max_execution_time to unlimited, and probably other things just to get the server set up properly, it still fails...

This is for a photography website and I really need to be able to share photos with clients. I'm on a Bluehost server.

Any help would be appreciated!

Under review

Are you using a shared hosting account, or a VPS? If shared, then you are most probably hitting limitations set on your server from the service provider (and not a PHP limit).

Closed for lack of information

I had/have the same Problem (LINK), its not solved untill now. But it somehow cant be a PHP Limit, as my PHP limit is set to 100GB (yes I have more then 100GB RAM)

If I download files over DAV (WebDAV) I have not any problem, but if I download it from the Browser i get a empty file if the magic 6,8GB are reched and the download is interrupted.

Also installing "mod_xsendfile" is not solving the problem.

Some WebDAV client programs transfer large files in chunks, or automatically resume interrupted transfers. Otherwise the transfer is done the same way as through a browser.

It can be a FastCGI, or HTTP server configuration limitation (timeout - usually set to prevent denial-of-service attacks).

We can look into it for you if you contact us (https://www.filerun.com/contact) with remote access to your FileRun installation folder.