Account gets deactivated

dj3tusk 2 years ago updated 6 months ago 9

Hey all!
I recently installed FileRun using the official Docker image. Everything worked great except, for some reason my account deactivates after some time. Not sure whats causing it. The account is question is the superuser account with account name changed. I'm currently on version  2019.05.21.

Any help is appreciated


Too many incorrect login attempts. It shouldn't happen on the superuser account thought, so we'll fix that.

To reactivate the account, the only way is through the MySQL database, running the query: UPDATE `df_users` SET `activated` = '1' WHERE `id` = 1


A FileRun update is now available. It includes a fix for this.

I just ran into this problem. Thanks for the solution, it worked. But the update you released may not have fixed it. 

Just fyi, I was logging in using a webdav app (Expandrive) and I typed my password in wrong. I received a random error message from Expandrive (401, 405). After three attempts (I get notified after failed attempts) I was locked out. 

Forgot to mention it was the superuser account.

Thank you for the report. Using 2019.06.01, I am not able to get the FileRun superuser account suspended. Tries also via WebDAV.

Are you using an authentication plugin in FileRun?

good morning, today the exact same thing happened to my superuser account

Keeping up with the software updates helps avoid problems.

My company took over IT support for a law firm that uses Filerun. I am trying to log into the superuser account and it is saying deactivated. First question, where do I run that command up above and how? Is it in the command-line tool for the database? Second question, how do I update the version? Do I need admin access to the application? ANY HELP IS APPRECIATED!!