Not working file upload and API after update to 2019.06.01

servis 3 years ago updated by Vlad R 3 years ago 5

Hi i have problem with file run. Everything working 1 year but now i update filerun to version 2019.06.01 and now when i put files to upload over fileuploader takes a very long time for very small files which is not normal. And second problem is thah API dont working, i get error "The item is no longer available!", but before i update filerun everything working.
Unfortunately, I do not have backup.

What can be wrong?

Under review

You have to be way more specific and descriptive than that. Take one problem at a time, and provide enough details for us to reproduce the problem.

I solve the problem with api in the previous version I had a path to a folder with a space like
'path' => '/ROOT/HOME/Servisna%20poročila/ 

now I had to delete the space (%20) and worked.

But i still have problem with uploading.
When I select a upload file, it loads immediately to computer only (4 byte file size), but the window does not close immediately. This has already happened to me before (one year ago when i firstly install this script, and i messed up someting with settings), but then I made a fresh installation and then it worked normal. But now i am nothig doing except upgrade. I can send you some LOG files. Becuse i dont want do another time fresh installation.

Here i upload video of screen, so here you will see waht is the problem: https://drive.google.com/file/d/1UuGAcbrVUG_Uf3zliLDOlM3l7UzQhkvA/view?usp=sharing

If i upload bigger files it take much more time to upload.


Have you configured any e-mail notifications? Try to uncheck the "Instant email notifications" option from under the e-mail settings in FileRun's control panel. If that makes things better, then you will know that your SMTP settings are not correct or your SMTP server is unresponsive.

Edit: reinstalling FileRun won't change anything

Yes now it's working. And I have a few days of problems with the SMTP server. Thank you