0
Not a bug

Files data directly displayed in browser instead of downloading the file

olokos 1 year ago updated by Vlad R 1 year ago 9

Hello, 

I'm running:

PHP7.3, MySQL 8.0.10+, Apache 2.4, Ubuntu server 18.04 LTS

for some reason after many updates filerun doesnt download a file via link created, but displays its data in browser as text instead

For example instead of photo.jpg downloaded - browser displays data as viewed using notepad++.

Sample link

https://www.files.olokos.pl/wl/?id=MCeDihTf5XvHq8RCqbh81rlRoAACLIL8

Weird thing is if I download while logged into filerun it redirects me there:

https://www.files.olokos.pl/?module=fileman§ion=do&page=download&archiveName=nolockscreen.suprx

Then the file downloads properly, really odd.

Under review

Try to set "Enable download accelerator" to "None" under Control Panel > "Files" > "Misc options".

Have you edited any FileRun files at all?

Are you using a reverse proxy?

I haven't done any modifications to filerun apart from those within the filerun webpanel itself.

I am not using reverse proxy for filerun at all

Here's my apache2 virtualhost for filerun

https://termbin.com/w6g0

I have just recently added the filesmatch .php and it makes absolutely no difference for this issue, whether I have it or not - apart from website loading speeds, those have improved, but please do feel free to correct any mistakes you would spot here, it would be much appreciated.

Not a bug

The HTTP headers sent out by your web server does not match what FileRun sends. For example "Content-Type" is missing and "Content-Disposition" is overwritten with modified values. I can tell you this for a fact, but I wouldn't know what exactly is causing this in your setup.

Could it be that this is because I am using HTTP/2 protocol?

I don't know.

If you can't find what is causing this, you can also enable the option "Prevent the browser from opening the file." in the web link's advanced settings.

I disabled HTTP/2 protocol, but it makes no difference :(

I cannot find "Prevent the browser from opening the file." option anywhere on top of that :/


Any suggestions where I should go looking for something that is causing this?

I cannot find "Prevent the browser from opening the file." option anywhere on top of that :/

In the "Share" > "Web Link" panel, click "Advanced".

Any suggestions where I should go looking for something that is causing this?

I would review the way PHP-FPM is installed in Apache, perhaps trying a reinstall.