0
Answered

Thumbnail problem for Office files

Petr M 7 months ago updated by Vlad R 7 months ago 5

FileRun creates no thumbnails for doc, xls etc., but pdf, png etc are ok. (To be accurate: Once a png thumbnail wasnt created, only when shared with another user or when moved to another folder (using the web interface) - in the old thumbnail folder (checked from the command line) was a lock file). The LibreOffice is installed on the server, the conversion to png is ok from the command line, FileRun can see the LibreOffice (from the settings). But only lock files are in the folders for doc/xls/etc thumbnails. Any advices?

Under review

Please right-click a file, select the “More options” -> "Control panel" -> "Thumbnails generation" and copy here the text output so that we can help.

+1

Hello, thank you, here it is:

Debugging is on (1588583389)
Request options:
Array
(
    [skipNotification] => 1
    [caching] => 
    [debug] => 1
)
In use options:
Array
(
    [skipNotification] => 1
    [caching] => 
    [debug] => 1
    [width] => 400
    [height] => 400
    [geometry] => contain
    [pageNo] => 0
    [forceExt] => doc
)
Processing: /var/www/icko1_data/superuser/Projekt02/testovaci2.doc
As: doc
File size: 33280 bytes (33 KB)
Removing expired lock: /var/www/icko1_data/superuser/Projekt02/.filerun.thumbnails/testovaci2.doc/33280/400_400_contain[1].png.lock
Creating lock: /var/www/icko1_data/superuser/Projekt02/.filerun.thumbnails/testovaci2.doc/33280/400_400_contain[1].png.lock
Extractor: \FileRun\Thumbs\Extractors\office
Converting office document to image.<br>Running: soffice --headless --nologo --nofirststartwizard --norestore --convert-to jpg:writer_jpg_Export --outdir "/var/www/icko1_data/superuser/Projekt02/.filerun.thumbnails/testovaci2.doc" "/var/www/icko1_data/superuser/Projekt02/testovaci2.doc" 2>&1<br>Extracted to: /var/www/icko1_data/superuser/Projekt02/.filerun.thumbnails/testovaci2.doc/testovaci2.jpg
Extracted file size: 420234 bytes (410 KB)
File is safe for web.
File is smaller than 8 MB.
Checking image resolution.
Image size is 794 x 1123
Requested size is 400 x 400
Moving extracted to cache.
Displaying cached image: /var/www/icko1_data/superuser/Projekt02/.filerun.thumbnails/testovaci2.doc/33280/400_400_contain[1].png
Thumb file size: 420234 bytes
Caching is off. Removing resized image.
Removing lock: /var/www/icko1_data/superuser/Projekt02/.filerun.thumbnails/testovaci2.doc/33280/400_400_contain[1].png.lock

Looks like everything works as it should.

Please try to clear your browser's cache, refresh FileRun, and navigate to the folder "/var/www/icko1_data/superuser/Projekt02/". FileRun should generate and fine the thumbnail for the file "testovaci2.doc".

Seems there was a problem with the LibreOffice cache earlier, then solved (thanks to your advice above) and then there was only another problem with the browser cache. Cache cleared and it is solved now. Thank you!