0
Fixed

Password Reset Issues with 2FA

Mark F 5 months ago updated by Vlad R 4 days ago 5

When you use the "Forgot Password?" function to reset your password, it lets you know that "You are required to change your password."  If you have 2FA turned on and you try to change your password it tells you "You can only change the password via the web interface!"  To change your password you have to close out the Account Settings box, open the Account Settings back up, turn off 2FA, click save changes, open the Account Settings again, change your password, and then turn 2FA back on.

Under review

Hi Mark! Sorry that you didn't get a reply to this post for so long.

I am afraid I couldn't confirm the problem. The "You can only change the password via the web interface!" error is supposed to happen only when trying to change the password via the API. Where did you get this error?

Here is how you can recreate the issue for a filerun account that has 2FA enabled. Also, I have linked a  video screenshot of the process.  I am using filerun 2019.12.25

  1. Click on your profile image and then "Account Settings"
  2. Enter your current password in the "Current Password" field
  3. Enter a new password in the "New Password" field
  4. Enter the new password in the "Confirm new password" field
  5. Click "Save Changes"

after these steps you are presented with the "Your account is configured with 2-step verification. You can only change the password via the web interface!" popup.


To successfully change your password on a filerun account that

has 2FA enabled you must follow these steps.

  1. Click on your profile image and then "Account Settings"
  2. Turn off 2FA by unchecking the "Enable 2-step verification" box
  3. Click "Save Changes"
  4. Click on your profile image and then "Account Settings"
  5. Enter your current password in the "Current Password" field
  6. Enter a new password in the "New Password" field
  7. Enter the new password in the "Confirm new password" field
  8. Click "Save Changes"
  9. Click on your profile image and then "Account Settings"
  10. Turn on 2FA by checking the "Enable 2-step verification" box
  11. Click "Save Changes"
Started

Got it, thank you! This will be fixed with the update that will be available in a couple of days.