0
Answered

Some way to avoid "copy" with upload?

lingerak 4 months ago updated 4 months ago 10

Hi,


i can upload (through for instance android app) files up to 10MB without problem. however it seems my hosting provider has some limitation on "COPY" command of files bigger than that, so each time i have a bigger backup or upload, the upload does finish but then i get an error message saying "COPY is not allowed", and the file never gets to the right location.

is there any way i can upload without the script needing that "COPY" command?


best,

david


Answered

FileRun uses no file copying actions for uploads.

hi,

thanks for your reply.

i think it's happening when it puts the chunks together. i get this error message: (see attachment)


files below 10MB go fine. larger it does upload all, but -after- that, i get this error message.


You need to configure your webserver to allow all WebDAV methods (HTTP request methods), including MOVE.

hi,

thank you for replying.

sadly my hosting provider doesn't allow the MOVE operation. so this is why i wondered if there's a workaround.

david

I am afraid not. There is no possible valid reason for why a server would not allow that. It is completely arbitrary and makes no sense.

hi,

they said something it's to avoid people setting up file servers.. well i don't see why me making some backups would stress their servers so much, it's not even streaming or real-time or so...

it's especially annoying because small files (< 10 MB) go ok, only above i get the error message, and the php file upload limit i can set to as high as 1GB.


well maybe i'll just settle for ftp uploads for the larger files...

david



btw, drag and drop through the web interface goes well, any size. only the android app and automatic upload from PC> 10 Mb fail.. :(


i read this somewhere in a forum:


Files smaller than 10MB:

/srv/www/htdocs/nextcloud/apps/dav/appinfo/v1/webdav.php

Files bigger than 10MB:

/srv/www/htdocs/nextcloud/apps/dav/appinfo/v2/remote.php


and : "Adding "client_max_body_size 100M;" to the location-setting in file nginx.conf fixed the issue."

but that file i don't think i can change. :(

I am afraid there is no way for you to fix this without the assistance of your server's admin.

...and they won't do it because they think it will be too stressful on the server! which i think is a bit ridiculous.

anyway thanks for checking into it! i'll try persuade them again later, to at least make uploads to 50mb or so on webdav possible.

david