Your comments

Yes, I was unable to access my installation on my server.

The problem is "lack" in Authorization apache configuration


My problem was fixed by adding the following:


SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1

before this one:

ProxyPassMatch ^/(.*\.php(/.*)?)$ fcgi://127.0.0.1:9000/var/www/wiki/$1

so proxy_module in filerun virtual host config looks like this:

<IfModule proxy_module>
SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1
ProxyPassMatch ^/(.*\.php(/.*)?)$ fcgi://127.0.0.1:9000/var/www/wiki/$1

thanks

Michael.

I've the same problem, the logs as follwoing:

[03-Apr-2019 19:25:56 UTC] PHP Fatal error: Uncaught Elasticsearch\Common\Exceptions\BadRequest400Exception: {"error":{"root_cause":[{"type":"mapper_parsing_exception","reason":"No handler for type [keyword] declared on field [path]"}],"type":"mapper_parsing_exception","reason":"Failed to parse mapping [all]: No handler for type [keyword] declared on field [path]","caused_by":{"type":"mapper_parsing_exception","reason":"No handler for type [keyword] declared on field [path]"}},"status":400} in /var/www/wiki/system/classes/vendor/Elasticsearch/Connections/Connection.php:615
Stack trace:
#0 /var/www/wiki/system/classes/vendor/Elasticsearch/Connections/Connection.php(279): Elasticsearch\Connections\Connection->process4xxError(Array, Array, Array)
#1 /var/www/wiki/system/classes/vendor/React/Promise/FulfilledPromise.php(25): Elasticsearch\Connections\Connection->Elasticsearch\Connections\{closure}(Array)
#2 /var/www/wiki/system/classes/vendor/GuzzleHttp/Ring/Future/CompletedFutureValue.php(55): React\Promise\FulfilledPromise->then(Object(Closure), NULL, NU in /var/www/wiki/system/classes/vendor/Elasticsearch/Connections/Connection.php on line 615

it looks like versioning problem. I'm using external elastic search and it work just fine with a lot of other apps.

i cannot reinstall it.

can you advice?