Your comments

I had/have the same Problem (LINK), its not solved untill now. But it somehow cant be a PHP Limit, as my PHP limit is set to 100GB (yes I have more then 100GB RAM)

If I download files over DAV (WebDAV) I have not any problem, but if I download it from the Browser i get a empty file if the magic 6,8GB are reched and the download is interrupted.


Also installing "mod_xsendfile" is not solving the problem.

I just set up a new instalaltion of FileRun and cant register, as no E-Mails are coming to my mail?

On the same Server I registered an other installation.

Is there anything that changed related to "sending Mails"?

Well I would just do it with the .htaccess if all the other things not work. I would even prefer to set up FileRun fresh with https.

But here you go:



ORIGINAL:

<IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
</IfModule>
SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1 <IfModule mod_php5.c>
   php_value error_reporting 22519
   php_flag allow_url_include 0
   php_flag allow_webdav_methods 1
   php_value memory_limit 256M
   php_value max_execution_time 300
   php_flag output_buffering 0
   php_flag zlib.output_compression 0
   php_flag file_uploads 1
   php_value max_file_uploads 10
   php_value upload_max_filesize 20M
   php_value post_max_size 20M
   php_flag enable_dl 0
   php_value default_charset 'UTF-8'
</IfModule>
<IfModule mod_php7.c>
    php_value error_reporting 22519
    php_flag allow_url_include 0
    php_flag allow_webdav_methods 1
    php_value memory_limit 256M
    php_value max_execution_time 300
    php_flag output_buffering 0
    php_flag zlib.output_compression 0
    php_flag file_uploads 1
    php_value max_file_uploads 10
    php_value upload_max_filesize 20M
    php_value post_max_size 20M
    php_flag enable_dl 0
    php_value default_charset 'UTF-8'
</IfModule> <IfModule mod_dir.c>
  DirectoryIndex index.php index.html
</IfModule> AddDefaultCharset utf-8
Options -Indexes

MODIFIED:

<IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]     RewriteCond %{HTTPS} !=on     RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=302]
</IfModule>
SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1 <IfModule mod_php5.c>
   php_value error_reporting 22519
   php_flag allow_url_include 0
   php_flag allow_webdav_methods 1
   php_value memory_limit 256M
   php_value max_execution_time 300
   php_flag output_buffering 0
   php_flag zlib.output_compression 0
   php_flag file_uploads 1
   php_value max_file_uploads 10
   php_value upload_max_filesize 20M
   php_value post_max_size 20M
   php_flag enable_dl 0
   php_value default_charset 'UTF-8'
</IfModule>
<IfModule mod_php7.c>
    php_value error_reporting 22519
    php_flag allow_url_include 0
    php_flag allow_webdav_methods 1
    php_value memory_limit 256M
    php_value max_execution_time 300
    php_flag output_buffering 0
    php_flag zlib.output_compression 0
    php_flag file_uploads 1
    php_value max_file_uploads 10
    php_value upload_max_filesize 20M
    php_value post_max_size 20M
    php_flag enable_dl 0
    php_value default_charset 'UTF-8'
</IfModule> <IfModule mod_dir.c>
  DirectoryIndex index.php index.html
</IfModule> AddDefaultCharset utf-8
Options -Indexes

I would implement a Serverside redirect to https, maybe something like this:


(belongs to the .htaccess)


RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=302]

Should redirect all traffic from http to https


If it works change the "302" to "301"

302 = temporary

301 = permanent


Pls test first woth 302

I think I know what you mean. You have installed a SSL Certificate but if some content still gets loaded over http (instead of httpS) it will 'break' the Certificate untill all of the content is beeing loaded over https.


I dont know if this is the Problem but it could be.

For me everything worked after installing the SSL Certificate and re-register the Installation.

Can you access your FileRun installation with https?

Any errorlogs?

Ok thanks I will try this extension and report back.

Thanks

If you serve parts of a website through http at a website which gets served over https this will break the SSL Certificate.

So Serving parts of the site over http when the webite itself get served over https does not make sence

Btw: this is a duplicated thread. ---> Link