Your comments

Sorry to comment on a closed thread. I see that this request has been confirmed. How do you make a search containing multiple tags? I tried using the modifiers AND, &, OR etc., but they did not work.

Bump?

Even a "See more..." link at the bottom, to load the next batch of files, would be useful.

Ok! Solved!


First of all, I used the metadata_index.php script and it scanned all the metadata successfully (it took a few minutes, but it's relatively quick). So Tags and Dates are now populated. I can run a cron job every night to scan and update the metadata if necessary.


Second, regarding the thumbnails, I created a folder to store all the thumbnails in the filebot directory instead of the default locations (on each path root?). now I keep them at /var/www/html/filerun/thumbnails/, and I edited the /var/www/html/filerun/customizables/config.php with the following content:


<?php
    $config['path']['thumbnail_cache'] = '/var/www/html/filerun/thumbnails/';
    $config['app']['thumbs']['output_small_filesize'] = 15728640;
?>


So far, it seems to generate all the thumbnails correctly. You can close this issue if you with.

Thanks for your response.


Imagemagick is enabled (Version: ImageMagick 6.9.7-4 Q16 x86_64), but even if I disable it, some thumbnails are generated, others don't (most don't). php extensions for Exif and XML are enabled:


root@box-media:/var/www/html# php -r "print_r(get_loaded_extensions());"
Array
(
    [0] => Core
    [1] => date
    [2] => libxml
    [3] => openssl
    [4] => pcre
    [5] => zlib
    [6] => filter
    [7] => hash
    [8] => pcntl
    [9] => Reflection
    [10] => SPL
    [11] => session
    [12] => standard
    [13] => mysqlnd
    [14] => PDO
    [15] => xml
    [16] => calendar
    [17] => ctype
    [18] => curl
    [19] => dom
    [20] => mbstring
    [21] => fileinfo
    [22] => ftp
    [23] => gd
    [24] => gettext
    [25] => iconv
    [26] => json
    [27] => ldap
    [28] => exif
    [29] => mysqli
    [30] => pdo_mysql
    [31] => Phar
    [32] => posix
    [33] => readline
    [34] => shmop
    [35] => SimpleXML
    [36] => sockets
    [37] => sysvmsg
    [38] => sysvsem
    [39] => sysvshm
    [40] => tokenizer
    [41] => wddx
    [42] => xmlreader
    [43] => xmlwriter
    [44] => xsl
    [45] => zip
    [46] => Zend OPcache
)


For some reason, when I try to run "metadata_index.php" from the command line, it complains that the ioncube PHP loader is not installer. However, when I check phpinfo() in the browser, ioncube is loaded. -


EDIT: Nevermind, I added the following line

zend_extension = /usr/lib/php/20151012/ioncube_loader_lin_7.0.so

to the /etc/php/7.0/cli/php.ini file and now ioncube is recognized from the command line.